Personal Website Help

User avatar
D-Rob
Posts: 121

Personal Website Help

Post#1 » Mon May 01, 2006 12:04 pm

I am currently developing a website that needs text to appear below a link when it is rolled over using only css. This isn't hard to do, but I do not want to use span tags to achieve it. I have seen it done, but the website is no longer available for me to steal the code from it. All I remember is that they used hyperlinks and the property "content: " was used, but I can't get it to work when I hover over the link.

Any help would be appreciated.

And if you help me, I'll stick in a link to your webpage as some sort of payment. :)

User avatar
Grep
Posts: 231

Personal Website Help

Post#2 » Mon May 01, 2006 3:02 pm

Is there any special reason you don't want to use a span tag? you do actually need some sort of inline tag. a div with display:inline; might work - but it does have to be somthing that isn't block level.

User avatar
Grep
Posts: 231

Personal Website Help

Post#3 » Mon May 01, 2006 3:31 pm

Well I did some quick testing, and it works with just about anything - including font's and div's. Here's a quick example with the html 4 transitonal dtd and a div tag. If you need anymore help let me know.



Test Page

User avatar
D-Rob
Posts: 121

Personal Website Help

Post#4 » Mon May 08, 2006 4:06 pm

I may not remember much from that site I mentioned, but I do know that wasn't it. However, what you gave me works especially well!!! I tried something similar to that, but I couldn't quite get it to work. I have only been learning html/css for half a year so I'm not familiar with what works here or there. Because of this, I really appreciate your help!!!

My webpage is http://icidweb.xoompages.com. The code I am using right now doesn't work in IE, except version 7 beta and it's buggy in that. I will shortly change everything to what you gave me!!! My site is mostly just someplace to test my webpage skills as I need a LOT of practice if that's what I want to do in life. I'm not even 18 yet, so I have plenty of time to practice!!!

Also,I don't want to sound greedy, but if I have questions here and there, you won't mind answering them will you?

User avatar
Grep
Posts: 231

Personal Website Help

Post#5 » Mon May 15, 2006 3:30 pm

No worries D-Rob, happy to help.

User avatar
aragorn's lady
Posts: 89

Personal Website Help

Post#6 » Sat Aug 26, 2006 7:19 am

This post has been moved to the Chat Problems thread

click here to go to post

Vee

User avatar
grondmaster
Posts: 25451

Personal Website Help

Post#7 » Mon Aug 28, 2006 5:17 pm

Grep hasn't been available for a while D-rob; I'm sure he will try to answer your question when he gets time. I checked out the above link and I saw the difference between Mozilla and IE6; I'm still using WIN 98 2nd edition and I know nothing about making webpages.
'Share and enjoy'

User avatar
D-Rob
Posts: 121

Personal Website Help

Post#8 » Mon Aug 28, 2006 5:35 pm

I have yet another web question. Go here using a Mozilla browser, then go to it in IE 6. It displays wrong because of a couple "position: absolute"s in the css, but why? On pages where 3 "absolutes" are used, if 1 is taken out, it works (well, doesn't display it all crammed together). On pages with 2, if 1 is taken out, it does the same thing. Also, if I change my doc type to html 4.0 instead of xhtml, it displays correctly. Think perhaps that it's just a bug in IE 6? If you have IE 7, tell me if it displays right because I'm using Win 2k and IE 7 isn't compatible...

Return to “Website Help”

Who is online

Users browsing this forum: No registered users and 1 guest